Recent Blogs Posts

  1. ECU re-map/re- chip for 120?

    Quote Originally Posted by NingNong View Post
    G'Day. I'm a rookie here, and not sure if this is the correct place for this comment, but here goes anyway. I have a 2003 Prado KZJ120R TurboDiesel (purchased second hand last year 180k Km ). I require more grunt and better economy (getting a constant 13l/100km open road, not towing) , so put on a 3in exhaust and an Ozbush manual mapper. Fuel consumption dropped by 0.4 l/100 on the open road with Ozbush mapper set at -10. I then had a dyno test to find 63 Kw at wheels Ozbush off, and 65Kw with Ozbush
    ...
    Categories
    Uncategorized
  2. Safari Snorkel Fitted

    Quote Originally Posted by jacquesleroux View Post
    Fitted a Safari Snorkel to our 2012 Kakadu today and the hardest part was drilling that first hole and hoping it's in the right Spot 😅
    The instructions and template from Safari make it so easy. Just need a sharp hole saw and a lot of guts. The missus had to walk away when I fitted mine a few years ago. Just about to have a go on my new 2.8.
    Categories
    Uncategorized
    Attached Thumbnails Attached Images
  3. Help with subscription

    Hi,

    Could someone involved in looking after subscriptions please email me so I can sort out my problem?

    Thanks,\......
    Categories
    Uncategorized
  4. KZJ95 Prado 1997 5 seater rear anchor points for child seats

    Quote Originally Posted by terrano4 View Post
    Hey out there, just brought a 1997 tx Prado and looking for the car seat anchor points for the kids. Have taken out the carpet in the rear tray and can see the cargo loops, there are also a couple of bungs that seem to be in the right position behind the seats but when removed are just plugging a 20mm approx diametre hole?? The cargo loops do not seem to be lined up with the centre of the seats in the back..... not sure whether to replace cargo loops with proper anchors or if the 20mm holes that
    ...
    Categories
    Uncategorized
  5. Hey guys pls help!

    5 weeks ago I took my wagon in for its 150000k service. I have a family friend that has done every 10000k service since I bought it (which was at 100000k's). Each 10K service has gone off without a hitch, all has been good. The 150K service was due and the "T-belt" light was illuminated saying it required a timing belt replacement. After the full service was completed I've received a fonecall from my mechanic asking "how long have these engine lights been displayed for"....... ...
    Categories
    Uncategorized
Page 1 of 53 1231151 ... LastLast