Announcement

Collapse
No announcement yet.

ABS accumulator squeaking soud after ABS pressue pump stope- repeats every 4 seconds

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ABS accumulator squeaking soud after ABS pressue pump stope- repeats every 4 seconds

    Hi guys,

    I have a 2007 Prado 120 series (120,000k)

    Every 4 seconds or so the ABS pump kicks in and a very audible squeal is heard (it's loud inside the cabin).

    Have googled and found a video very similar to what I am experiencing:

    http://www.youtube.com/watch?v=sh14T2Yq2ZE

    the best explanation I can come up with is that the ABS pump is pressurizing the accumulator and when the pump turns off it returns back past some valve, the valve is leaking (maybe due to an air lock) causing the noise.

    The returning pressure is vibrating a seal somewhere making a sound in much the same way as if you let air from a balloon while pinching closed the opening.

    there are no warning lights on, breaking seems fine

    Mu friendly local mechanic (friend of the family) took it to Toyota as he wasn't game to work on it. This was the start of warning bells happening. Toyota, in their infinite generosity, quoted me $3000 for the privilege of letting them repair it for me.

    I took it to another the local shop (Ultratune) for 2nd opinion and they bled the brakes and said there was air in the lines. all good!

    Alright! $3000 back in my pocket

    $285 and 3 days later the noise returned.

    Took it back to the shop and they speculated that air was still getting into the lines. they suggested sending it to a "specialist"...$60 to quote for it and saying anything up to $1800 (better than $3000 at least)

    hmmmm.

    The brake booster assembly is now interstate for a quote with some specialist but I can't help but think I've got sucker stamped on my forehead here, there's gotta be an explanation and surely someone else has had this problem before? what happened to the guy in the video above?.

    Maybe they did not bleed it properly. the brakes are fine and not spongy, stops well, no error codes.

    One thing I haven't done yet (in hind sight) is forced the ABS to work to see if it pushes any air through the accumulator and so stop the squeaking...

    running out of ideas, please help

  • #2
    Read somewhere that the accumulator (pressure cyclinder) can loose pressure, I think it can be changed
    or repressurised without the need to change the whole booster.

    Maybe someone else can supply more info.

    Leigh
    HKB Electronics, manufacturer of the Alternator Voltage Booster, Silver 2008 D4D,Lifted,Underbody protection, Alternator Voltage Booster, Tiger Z winch, Lightforce DL, Air Horns, Tanami Drawers, Drop down fridge slide, Outback cargo barriers, Rotronics dual Battery system, Polaris GPS, HF/UHF/VHF, Radio speaker combiner, Long ranger water tank, Diff breathers, Inverter, Snorkel and others

    Comment


    • #3
      Roo told me about this being a 'common' 120 weak point when I mentioned recently had my ABS unit replaced by Toyota. I suggest you contact him and have a chat about the options other than new (mine was under warranty). He did mention a rebuild of some kind was a cheeper option.


      pptg(at)dodo.com.au
      2[FONT=Arial Narrow]008 Prado GXL D4D Auto with Prado Pack

      4x4 History: 2000 Prado GXL 90 Series 1KZ-TE, 1992 4runner 2.8 Motson turbo, 1985 Landcruiser 60 Series 3.9L Diesel, 1985 4Runner 2L 2.4 Diesel later mod. + 2.4T (Factory Turbo), 1982 Hilux 2.2L Diesel in Yellow (callsign 'Yellow Peril') later mod. + 2.4L engine[/FONT]

      Comment


      • #4
        Originally posted by peril View Post
        Roo told me about this being a 'common' 120 weak point when I mentioned recently had my ABS unit replaced by Toyota. I suggest you contact him and have a chat about the options other than new (mine was under warranty). He did mention a rebuild of some kind was a cheeper option.


        pptg(at)dodo.com.au
        Can I get some help contacting Roo? how do I contact him?

        thanks in advance.

        hopefully this is a common 120 problem, maybe there's a known correction.

        Comment


        • #5
          The email address I put in above letter is Roos email address. (replace (at) with @)
          2[FONT=Arial Narrow]008 Prado GXL D4D Auto with Prado Pack

          4x4 History: 2000 Prado GXL 90 Series 1KZ-TE, 1992 4runner 2.8 Motson turbo, 1985 Landcruiser 60 Series 3.9L Diesel, 1985 4Runner 2L 2.4 Diesel later mod. + 2.4T (Factory Turbo), 1982 Hilux 2.2L Diesel in Yellow (callsign 'Yellow Peril') later mod. + 2.4L engine[/FONT]

          Comment


          • #6
            Did anyone find a correction foe this? I am now having abs issues with my 120.

            Thanks in advance. Scott

            Comment

            Working...
            X