Announcement

Collapse
No announcement yet.

Installing OBD2 bluetooth scanner on M-OBD Prados

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Not sure what I am doing wrong. Have an early 04VX (1kz)
    bought the ELM327 V1.5 adaptor as suggested above, it has the mac address starting 00:00 but I still can’t get it to connect.
    Ive tried it with the string and without.. the screen shot below is the best I can get... any ideas?

    now it won’t let me upload a photo
    All green ticks apart from “connection to ecu” which has a exclamation mark and is in orange
    Attached Files

    Comment


    • What code reader works on pre sept 04 1kzte thanks.To be more specific a reader that is a stand alone not blue tooth I bought one cost 120 and wont read prado,reads the yaris just want to read faults etc.

      Comment


      • Is the ignition on? And the adapter paired to the tablet?

        Comment


        • I’ve been trying with the engine running. Should I try just with ignition on?
          yes the adaptor is paired with the laptop, it is communicating fine with torque pro, just can’t connect to the car

          Comment


          • As long as the ignition is on or running it should be able to communicate. Double check the string.
            Which adapter did you get?

            Comment


            • i bought this one

              https://www.ebay.com.au/itm/2017-Vga...4AAOSwh6xTsUCT

              It connects to my 2014 Subaru Liberty and my 2018 Rav4 straight away but i cant seem to get it to connect to the prado..

              I have played around with the string and still nothing..
              i get a tick for
              -bluetooth enabled
              -connection to adaptor
              -adaptor error count

              but a warning exclamation mark for connection to ecu

              Comment


              • Originally posted by crowey View Post
                i bought this one

                https://www.ebay.com.au/itm/2017-Vga...4AAOSwh6xTsUCT

                It connects to my 2014 Subaru Liberty and my 2018 Rav4 straight away but i cant seem to get it to connect to the prado..

                I have played around with the string and still nothing..
                i get a tick for
                -bluetooth enabled
                -connection to adaptor
                -adaptor error count

                but a warning exclamation mark for connection to ecu
                That seller has changed the design or the source of where they got their units from and their current unit does not talk to M-OBD ECUs. There is another unit in the last few pages of this thread which others have claimed to work.
                If you have experienced D4D engine failure, please complete this survey ​http://goo.gl/forms/bpJSYjq0Zx
                My Rig Build up

                sigpic

                Comment


                • Originally posted by amts View Post

                  That seller has changed the design or the source of where they got their units from and their current unit does not talk to M-OBD ECUs. There is another unit in the last few pages of this thread which others have claimed to work.
                  Ahh bugger, i bought the identical unit that damien suggested... the seller he bought his through dont have any for sale at the moment.. looks like ive got a dud!
                  FFS

                  Comment


                  • The one Damienh mentioned below looks like this unit https://www.ebay.com.au/itm/KW903-EL...QAAOSwyKhbYaF~
                    Is that what yours looks like?

                    Originally posted by Damienh7 View Post
                    I have just recently bought one that works with my '05 4 speed auto 1kz-te Prado.

                    Bought off ebay, title description is "KW903 OBDII OBD2 ELM327 Bluetooth Car Code Reader Scanner Diagnostic Tool Useful" from seller called "helloclient".

                    Successfully communicating with the Torque Pro app, and just starting to play around with gauges, deciding what I want to track! Was there a final verdict on ability to track transmission temp? I'm about to do a 3 month stint towing a 1.8t van around Oz, and that's one I'm keen to keep an eye on, along with coolant temp considering overheating/head issues are one of the main known issues with this engine.

                    Cheers,
                    Damien
                    If you have experienced D4D engine failure, please complete this survey ​http://goo.gl/forms/bpJSYjq0Zx
                    My Rig Build up

                    sigpic

                    Comment


                    • Thanks Andrew, looks like i have bought the wrong one! (ill blame facebook for that)!
                      Have just bought the in the link you attached above, will see how we go with that one when it gets here next week!

                      Comment


                      • I suspect that it's to do with the version of the chip so it's all a bit of a hit and miss. The one that I have which works is one I got about 5 years ago, like the one below with v1.4 hardware.
                        I have a more recent purchase which connects via wifi instead of Bluetooth and when I tested it out today, it didn't connect to the vehicle.

                        https://www.ebay.com.au/itm/QR-Code-...oAAOSwp55Zet5s

                        Comment


                        • Can confirm this one works correctly with torque pro on my early 04vx

                          https://rover.ebay.com/rover/0/0/0?m...2F283081419429

                          Comment

                          Working...
                          X