Announcement

Collapse
No announcement yet.

Another Question On 120 Series Air Suspension

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Another Question On 120 Series Air Suspension

    Hi All
    I'm a Newby in here but I'm guilty of lurking for awhile. You guys all put up heaps of helpful stuff.
    I've had the same issue with my 05 Grande that a lot of you have. I blew an airbag on a camping trip and have replaced them both. But I can't get the system to kick back in. I've got power to everything except the compressor. I hotwired it so I know it still works but even when I do that only one side fills up the left bag gets no air going to it. The lines all seem okay and I can't hear any leaks. I pulled the sensors and tested them with my multimeter and I think they are okay. I unplugged the suspension ecu and let it sit but I just can't get it to fire up. Does anyone have any advice they could give please? Maybe the solenoid on the air tank has packed it in? I'm not sure and I'm running out of ideas and sanity 😂 Thanks in advance.

  • #2
    Don't over cook the question. First rule.

    The compressor and height system will shut down for progressively longer periods if it can't fill the bags. (Leak burst whatever).
    It will be 10mins the first couple times then go to 70 minutes. !!

    On mine it did this.
    I reset all the trouble codes after installing a new bag.
    Disconnected battery for 60.
    Plugged back in left for 1.5 hours. Turned car on and it started up.

    When you play around with them it can extend the shutdown time.

    Comment


    • #3
      Hey, thanks for the info. I gave it a go and didn't have any luck. It's got me beat. Cheers

      Comment


      • #4
        How did you clear the codes? It should have some errors showing.

        Comment


        • #5
          I just unplugged the suspension ecu took the fuses out and disconnected the battery.

          Comment


          • #6
            Codes will still be in it then. You'll need a tech stream, scangauge or some other way of clearing codes.

            Comment


            • #7
              So I finally got a techstream and cleared a heap of codes. And boom it seems to be working again. Thanks heaps for the help. 😀

              Comment


              • #8
                Good to hear it was as I thought and has worked for you.

                Did you take note of what codes?

                Comment


                • #9
                  It was basically every code it can throw I'm thinking 😂. Low pressure, height sensors, compressor. .. and 3 or 4 others. I'll learn for next time. Thanks again.

                  Comment


                  • #10
                    Yep. That's what I had.
                    The good thing is we seem to have found the correct way to get them fixed from this situation.

                    Comment


                    • #11
                      ok Guys to clear the codes for the air suspension short out the terminals 13 & 4 on the DLC3 to get the fault codes and when the lights start flashing press the brake pedal 8 times a beeping noise will come on and the system should restart.

                      Comment

                      Working...
                      X