Announcement

Collapse

  
See more
See less

'09 J150 V6 Prado intermittent electrical ticking dash

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • '09 J150 V6 Prado intermittent electrical ticking dash

    Hi All,

    Picked up my first Prado a couple of days ago and very happy with car! Massive upgrade from my old agricultural 1KZte Hilux.

    Just a quick question i don't think its really of any concern.
    On start up there is intermittent ticking coming from behind the speedo cluster area. Sounds electrical like a switch/relay.
    On cold start in the morning there is approx 5 single ticks spaced around 5 seconds apart. Warm start maybe only 1 or 2 ticks, sometimes none
    Again this is probably nothing but just wanted to check in case its a more serious underlying issue.

    I have tried the search bar just in case this topic has been covered already.

    Update: Also just started today styrofoam type squeek from passenger foot well. Sounds like a duct or something going up and going back down once.



    Thanks in advance gents!

    Mike.
    Last edited by AndOr_gxl; 13-07-2019, 02:49 PM.

  • #2
    Are the 5 clicks before you crank the engine (i.e. when you turn the ignition to ON but not START) or after? Could be fuel pump, usually these come on a few seconds when you turn the ignition on.

    As for the squeak usually the glovebox pops out if you squeeze the sides when out and that gives more access to the air ducts etc.

    Comment


    • #3
      Originally posted by RedAdventureWagon View Post
      Are the 5 clicks before you crank the engine (i.e. when you turn the ignition to ON but not START) or after? Could be fuel pump, usually these come on a few seconds when you turn the ignition on.

      As for the squeak usually the glovebox pops out if you squeeze the sides when out and that gives more access to the air ducts etc.
      The clicks start a few seconds after the engine starts and continues intermittently for about a minute. Sounds like a relay click and seems to be more of them on morning cold start. Might just have to live with it but thought i might be able to narrow it down if i can find out what diagnostic checks the ecu is doing on cold start.

      As for the squeek i narrowed it down to the motor that pulls the side mirror in on the passenger side. Something wasn't engaging so just pulled the in and back out again and went away.

      Thanks for the reply RedAdventureWagon

      Comment


      • #4
        AndOr_gxl Mine clicks for the AC after engine start, so maybe it's getting that system going or similar. I also hear the brake pedal switch click on and off as I press the pedal, this was bugging me for a while before I twigged what it was

        You could always try pulling non-essential system fuses (AC, stereo, etc.) in turn and see when the clicks stop!

        Comment


        • #5
          When the clicking occurs, if you change the AC temp to either very hot or very cold, does the ticking go away?
          If you have experienced D4D engine failure, please complete this survey ​http://goo.gl/forms/bpJSYjq0Zx
          My Rig Build up

          sigpic

          Comment

          Working...
          X