Announcement

Collapse
No announcement yet.

Factory Sub Tank problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Factory Sub Tank problem

    Hi Folks,

    New member here. Been searching around for a solution to this question but can't seem to get an answer relevant to my problem. So problem is this: 2000 95 Series 1KZ with factory sub fuel tank. Have my Prado about 4 years, have always filled both tanks and and run them both down to 1/4 before filling again. Never let them run dry and never had an issue before this. The other day main tank was on 1/4, was driving on sub and gauge was showing just over 1/4. Was feeling a little pull on the car, thought it was just strong wind as I live on the coast. 2 mins later, Percy dies in the arse while driving at 90kph. Lost all power and had to quickly pull in, luckily happened in a spot where I could get off the road easily and safely (had the missus and kid with me)

    Saw a puff of smoke out the back just as it died, pulled in, tried cranking and was turning over but no start. Tried a couple more times and nothing. Was about to rip the timing cover off when I thought I'd just switch back to main tank and try it. Turned key on and off a few times with cranking and pressed accelerator to pump fuel, she started! Drove home no issues. When I got home I unloaded the missus and kid and switched back to sub and went for a drive around the block. After a couple of minutes she died again. I presume I was still running on whatever was left in the fuel lines. So switched back to main tank again and boom, started no problem.

    So I think I can safely assume it's an issue with the sub tank. With the car switched on (not running) I can her the solenoid clicking across when I switch tanks, so I think that side is ok. Gauge is still reading over 1/4 but here's where my problem kicks in. I drove around for a few days previous to this with the dash dismantled as I was having and issue with the AC and was waiting on parts. The sub gauge was disconnected for these few days but I was running on that tank not the main. I am wondering is the gauge simply wrong and tank is empty or is it the pump in the sub that's the issue. Does anyone know if driving with the gauge disconnected would cause a problem with the reading, as in it didn't register the fuel I used for the few days I drove around? Tried disconnecting battery to reset gauge but it crept back up to where it was. I got under and tapped the sub and it sounds empty, the bolts holding it in are really seized so I was wondering two things: 1: Is there a process for resetting the gauge and 2: Does anyone know the capacity of the sub? I want to fill her up and see if it was just run dry but don't know the exact capacity and can't find the info anywhere. Any advice would be awesome. It's our daily driver and cash is a bit tight so I'd prefer the easy checks before I take the route of buying tools and possibly new pump. Thanks for reading, sorry for the long post was just trying to include the details as I've seen similar issues on this and other forums but nothing specific to my circumstances.

    Cheers

  • #2
    Sub tank capacity is 69 litres, petrol models have a in tank pump in both tanks but I think the diesel doesn’t. I think the diesels have a lift pump which draws from both tanks ( one at a time controlled by the solenoid valves)

    Lee
    02 VX, Toyota Alloy Bar, IPF 900XS with 50 watt HID, 50 mm Lift- Lovell Shocks n Springs, Safari Snorkel, large Pioneer tray, Pioneer In-dash, Alpine roof mount DVD screen -handled the Simpson and Innaminka roads, now with a little TRD blower & Unichip

    Comment


    • #3
      Excellent thanks mate, I'll fill her up and see how much she drinks

      Comment


      • #4
        Just an update on this, been busy with Xmas. Finally got around to putting some juice in the sub tank. I didn't fill it, just put about $25 in so if I had to drop the tank out it wasn't full of diesel. The amount I put in was enough to lift the needle past where it was (moved up to almost half way). So I switched to sub and went for a drive and no issues so it's best case scenario imo, the sub is working and the gauge is the problem. I'll run the tank down over the next week and see if the needle moves freely. If not I was told there's access from under the back seat so I'll have a look from there if needed.

        Comment

        Working...
        X